初学者的烦恼
程序员文章站
2022-04-09 22:22:03
...
初学者的烦恼
时间限制:1000 ms | 内存限制:65535 KB
难度:1
- 描述
-
小c才开始学习c语言,让他最烦恼的就是对字符数组的操作。小C的好朋友小E为了激励他,出了这样一个题目:字符串的移动输出。并给他许诺说,如果他能够在有限的时间内编写出这道题目的代码,并顺利通过就请他去吃大餐,于是小C便认真的敲这个题目的代码去了,聪明的你也来练练手吧。
- 输入
- 第一行包括一个整数t,代表有t组数据;
每组数据第一行包括一个整数m(1<=m<=50),第二行有m个小写英文字符,第三行包括一个整数n(0<=n<=100),代表字符串向左移动n位。
- 输出
- 每组数据输入站一行,即输出移动后的字符串。
- 样例输入
-
3 5 asdfk 0 5 asdfk 1 5 asdfk 6
- 样例输出
-
asdfk sdfka sdfka
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner scanner = new Scanner(System.in);
int times = scanner.nextInt();
while (times-- != 0) {
int len = scanner.nextInt();
String temp = scanner.nextLine();
String str = scanner.nextLine();
int move = scanner.nextInt();
byte[] arr = str.getBytes();
for (int i = 0; i < move; i++) {
byte ch = arr[0];
for (int j = 1; j < len; j++) {
arr[j - 1] = arr[j];
}
arr[len - 1] = ch;
}
str = new String(arr);
System.out.println(str);
}
}
}
上一篇: MAC python matplotlib.pyplot 图形中文乱码
下一篇: 初学者的开端