POJ ACM习题【No.1969】
程序员文章站
2022-04-08 13:53:01
...
Count on Canton
Time Limit: 1000MS | Memory Limit: 30000K | |
Total Submissions: 5589 | Accepted: 3228 |
Description
One
of the famous proofs of modern mathematics is Georg Cantor's
demonstration that the set of rational numbers is enumerable. The proof
works by using an explicit enumeration of rational numbers as shown in
the diagram below.
In the above diagram, the first term is 1/1, the second term is 1/2, the third term is 2/1, the fourth term is 3/1, the fifth term is 2/2, and so on.
1/1 1/2 1/3 1/4 1/5 ... 2/1 2/2 2/3 2/4 3/1 3/2 3/3 4/1 4/2 5/1
In the above diagram, the first term is 1/1, the second term is 1/2, the third term is 2/1, the fourth term is 3/1, the fifth term is 2/2, and so on.
Input
The input list contains a single number per line and will be terminated by endof-file.
Output
You
are to write a program that will read a list of numbers in the range
from 1 to 10^7 and will print for each number the corresponding term in
Cantor's enumeration as given below.
Sample Input
3 14 7
Sample Output
TERM 3 IS 2/1 TERM 14 IS 2/4 TERM 7 IS 1/4
此题最大的难点在于需要区分左右方向。
import java.util.*;
public class Main {
public static void main(String[] args) {
Scanner cin = new Scanner(System.in);
while(cin.hasNext())
{
int num = cin.nextInt();
int index = 1;
int result = 0;
while(result <= num)
{
result += index;
index ++;
}
result -= (index-1);
int layer = index - 1;
int offset = num - result;
int up, down = 0;
if(layer % 2 == 0)
{
if(offset == 0)
{
up = 1;
down = layer - 1;
}
else
{
up = offset;
down = layer + 1 - offset;
}
}
else
{
if(offset == 0)
{
up = layer - 1;
down = 1;
}
else
{
up = layer + 1 - offset;
down = offset;
}
}
System.out.println("TERM " + num + " IS " + up + "/" + down);
}
}
}