欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

直角坐标系

程序员文章站 2022-04-04 10:42:44
...

Problem Description
X是一个喜欢数学的小孩,现在他刚刚学了坐标系。他想知道点(X,Y)在第几象限内。输入数据保证点不在坐标轴及原点上。
Input
多组输入。
每组输入两个整数X,Y,代表点(X,Y),中间用空格隔开。
Output
输出一个整数代表点在第几象限内。
Sample Input
2 3
-2 -3
Sample Output
1
3
Hint

Source
zmx

#include <stdio.h>
#include <stdlib.h>
int main()
{
    int x,y;
    while(scanf("%d %d",&x,&y)!=EOF)
    {
        if(x>0&&y>0)printf("1\n");
        if(x>0&&y<0)printf("4\n");
        if(x<0&&y>0)printf("2\n");
        if(x<0&&y<0)printf("3\n");
    }
    return 0;
}