欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

L1-027 出租 (20分)

程序员文章站 2022-04-02 10:55:47
...

下面是新浪微博上曾经很火的一张图:

L1-027 出租 (20分)

一时间网上一片求救声,急问这个怎么破。其实这段代码很简单,index数组就是arr数组的下标,index[0]=2 对应 arr[2]=1index[1]=0 对应 arr[0]=8index[2]=3 对应 arr[3]=0,以此类推…… 很容易得到电话号码是18013820100

本题要求你编写一个程序,为任何一个电话号码生成这段代码 —— 事实上,只要生成最前面两行就可以了,后面内容是不变的。

输入格式:
输入在一行中给出一个由11位数字组成的手机号码。

输出格式:
为输入的号码生成代码的前两行,其中arr中的数字必须按递减顺序给出。

输入样例:
18013820100
输出样例:

int[] arr = new int[]{8,3,2,1,0};
int[] index = new int[]{3,0,4,3,1,0,2,4,3,4,4};
#include <iostream>
#include <map>
using namespace std;

int main() {
	int flag = 0, flag1 = 0;
	string a;
	map<char, int, greater<char> >arr;
	cin >> a;
	for (auto it : a)
	cout << "int[] arr = new int[]{";
	for (auto &it : arr) {
		cout << (flag ? "," : "") << it.first;
		it.second = flag++;
	}
	cout << "};" << endl << "int[] index = new int[]{";
	for (auto it : a)
		cout << (flag1++ ? "," : "") << arr[it];
	cout << "};";
	return 0;
}
#include <iostream>
#include <string>
using namespace std;
int main() {
	string phone;
	getline(cin,phone);
	int num[11], temp[10]={0}, arr[10] = {0}, index[11]={0};
	for (int i = 0; i < 11; i++) {
		num[i] = phone[i] - '0';
		temp[num[i]]++;
	}
	int k = 0;
	for (int i = 9; i >= 0; i--) {
		if (temp[i] != 0) {
			 arr[k++] = i;
		}
	}
	for (int i = 0; i < 11; i++) {
		for (int j = 0; j < k; j++) {
			if (num[i] == arr[j]) {
				index[i] = j;
			}
		}
	}
	cout << "int[] arr = new int[]{";
	for (int i = 0; i < k; i++) {
		if(i != 0)	
			cout << ",";
		cout << arr[i];
	}
	cout << "};\nint[] index = new int[]{";
	for (int i = 0; i < 11; i++) {
		if(i != 0)	
			cout << ",";
		cout << index[i];
	}
	cout << "};";
	return 0;
}