【UVA】 1339 --- Ancient Cipher
【UVA】 1339 --- Ancient Cipher
Ancient Roman empire had a strong government system with various departments, including a secret
service department. Important documents were sent between provinces and the capital in encrypted
form to prevent eavesdropping. The most popular ciphers in those times were so called substitution
cipher and permutation cipher.
Substitution cipher changes all occurrences of each letter to some other letter. Substitutes for all
letters must be different. For some letters substitute letter may coincide with the original letter. For
example, applying substitution cipher that changes all letters from ‘A’ to ‘Y’ to the next ones in the
alphabet, and changes ‘Z’ to ‘A’, to the message “VICTORIOUS” one gets the message “WJDUPSJPVT”.
Permutation cipher applies some permutation to the letters of the message. For example, applying the permutation ⟨2, 1, 5, 4, 3, 7, 6, 10, 9, 8⟩ to the message “VICTORIOUS” one gets the message
“IVOTCIRSUO”.
It was quickly noticed that being applied separately, both substitution cipher and permutation
cipher were rather weak. But when being combined, they were strong enough for those times. Thus,
the most important messages were first encrypted using substitution cipher, and then the result was
encrypted using permutation cipher. Encrypting the message “VICTORIOUS” with the combination of
the ciphers described above one gets the message “JWPUDJSTVP”.
Archeologists have recently found the message engraved on a stone plate. At the first glance it
seemed completely meaningless, so it was suggested that the message was encrypted with some substitution and permutation ciphers. They have conjectured the possible text of the original message that
was encrypted, and now they want to check their conjecture. They need a computer program to do it,
so you have to write one.
Input
Input file contains several test cases. Each of them consists of two lines. The first line contains the
message engraved on the plate. Before encrypting, all spaces and punctuation marks were removed, so
the encrypted message contains only capital letters of the English alphabet. The second line contains
the original message that is conjectured to be encrypted in the message on the first line. It also contains
only capital letters of the English alphabet.
The lengths of both lines of the input file are equal and do not exceed 100.
Output
For each test case, print one output line. Output ‘YES’ if the message on the first line of the input file
could be the result of encrypting the message on the second line, or ‘NO’ in the other case.
Sample Input
JWPUDJSTVP
VICTORIOUS
MAMA
ROME
HAHA
HEHE
AAA
AAA
NEERCISTHEBEST
SECRETMESSAGES
Sample Output
YES
NO
YES
YES
NO
题意:
给定两个长度相同且不超过100的字符串, 判断是否能把其中一个字符串的各个字母重排, 然后对26个字母做一个一一映射, 使得两个字符串相同。 例如, JWPUDJSTVP重排后可以得到WJDUPSJPVT, 然后把每个字母映射到它前一个字母( B->A, C->B, …, Z->Y, A->Z) , 得到VICTORIOUS。 输入两个字符串, 输出YES或者NO。
思路:
既然字母可以重排, 则每个字母的位置并不重要, 重要的是每个字母出现的次数。 这样可以先统计出两个字符串中各个字母出现的次数, 得到两个数组arr1[26]和arr2[26]。 下一步需要一点想象力: 只要两个数组排序之后的结果相同, 输入的两个串就可以通过重排和一一映射变得相同。
AC代码:
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
int main()
{
char str1[110], str2[110];
while (cin >> str1 >> str2)
{
int arr1[26]{ 0 }, arr2[26]{ 0 };
int len = strlen(str1);
for (int i = 0; i < len; i++)
{
arr1[str1[i] - 'A']++;
arr2[str2[i] - 'A']++;
}
sort(arr1, arr1 + 26);
sort(arr2, arr2 + 26);
bool flag = true;
for (int i = 0; i < 26; i++)
{
if (arr1[i] != arr2[i])
{
flag = false;
}
}
if (flag)
{
cout << "YES" << endl;
}
else
{
cout << "NO" << endl;
}
}
return 0;
}
推荐阅读
-
UVA1339 - Ancient Cipher(思维)
-
UVA1339 Ancient Cipher(排序)
-
POJ2159 Ancient Cipher
-
Ancient Cipher UVALive - 3213
-
UVA1339 Ancient Cipher Java版
-
POJ 2159 Ancient Cipher G++
-
古老的密码(Ancient Cipher,NEERC 2004,UVa1339)
-
例题6-13 古代象形符号(Ancient Messages,World Finals 2011,UVa 1103)
-
1339 - Ancient Cipher 算法竞赛第四章
-
uva 1339 Ancient Cipher