计算几何学 | 直线的正交/平行判定 | Parallel/Orthogonal | C/C++实现
程序员文章站
2022-04-01 13:35:17
...
问题描述
对于直线s1、s2,当二者平行时输出2,正交时输出1.s1通过点p0、p1,s2通过点p2、p3。
输入:
第1行输入问题数q。接下来q行给出q个问题。各问题的点p0、p1、p2、p3的坐标按照以下格式给出:
输出:
对各问题输出2 1或者0,每个问题占1行。
限制:
1 ≤ q ≤ 1000
p0、p1不是同一个点
-10000 ≤ ≤ 10000
p2、p3不是同一个点。
输入示例
3
0 0 3 0 0 2 3 2
0 0 3 0 1 1 1 4
0 0 3 0 1 1 2 2
输出示例
2
1
0
讲解
下述程序示例可能会用到封装好的类和函数,详情请见:计算几何学 | 几何对象的基本元素与表现 | C/C++实现
由于cosθ在为90度和-90度时等于0,所以两个向量a、b正交⇔向量a、b的内积为0
也就是说,内积可以用来判断两个向量是否正交。
判断向量a和b是否正交:
bool isOrthogonal(Vector a, Vector b){
return equals(dot(a, b), 0.0);
}
bool isOrthogonal(Point a1, Point a2, Point b1, Point b2){
return isOrthogonal(a1 - a2, b1 - b2);
}
bool isOrthogonal(Segment s1, Segment s2){
return equals(dot(s1.p2 - s1.p1, s2.p2 - s2.p1), 0.0);
}
由于sinθ在θ为0度和180度时等于0,所以两个向量a、b平行⇔向量a、b的外积大小为0
也就是说,外积可以用来判断两个向量是否平行。
判断向量a和b是否平行:
bool isParallel(Vector a, Vector b){
return equals(cross(a, b), 0.0);
}
bool isParallel(Point a1, Point a2, Point b1, Point b2){
return isParallel(a1 - a2, b1 - b2);
}
bool isParallel(Segment s1, Segment s2){
return equals(cross(s1.p2 - s1.p1, s2.p2 - s2.p1), 0.0);
}
AC代码如下
#include<iostream>
#include<cmath>
using namespace std;
#define EPS (1e-10)
#define equals(a, b) (fabs((a) - (b)) < EPS)
class Point {
public:
double x, y;
Point(double x = 0, double y = 0): x(x), y(y) {}
Point operator + (Point p) { return Point(x + p.x, y + p.y); }
Point operator - (Point p) { return Point(x - p.x, y - p.y); }
Point operator * (double a) { return Point(a * x, a * y); }
Point operator / (double a) { return Point(x / a, y / a); }
double abs() { return sqrt(norm()); }
double norm() { return x * x + y * y; }
bool operator < (const Point &p) const {
return x != p.x ? x < p.x : y < p.y;
}
bool operator == (const Point &p) const {
return fabs(x - p.x) < EPS && fabs(y - p.y) < EPS;
}
};
typedef Point Vector;
struct Segment{
Point p1, p2;
};
double dot(Vector a, Vector b) {
return a.x * b.x + a.y * b.y;
}
double cross(Vector a, Vector b) {
return a.x*b.y - a.y*b.x;
}
bool isOrthogonal(Vector a, Vector b){
return equals(dot(a, b), 0.0);
}
bool isOrthogonal(Point a1, Point a2, Point b1, Point b2){
return isOrthogonal(a1 - a2, b1 - b2);
}
bool isOrthogonal(Segment s1, Segment s2){
return equals(dot(s1.p2 - s1.p1, s2.p2 - s2.p1), 0.0);
}
bool isParallel(Vector a, Vector b){
return equals(cross(a, b), 0.0);
}
bool isParallel(Point a1, Point a2, Point b1, Point b2){
return isParallel(a1 - a2, b1 - b2);
}
bool isParallel(Segment s1, Segment s2){
return equals(cross(s1.p2 - s1.p1, s2.p2 - s2.p1), 0.0);
}
int main(){
int q;
cin>>q;
Point p0, p1, p2, p3;
while(q--){
cin>>p0.x>>p0.y>>p1.x>>p1.y>>p2.x>>p2.y>>p3.x>>p3.y;
if(isOrthogonal(p0, p1, p2, p3) ){
cout<<1<<endl;
} else if(isParallel(p0, p1, p2, p3) ){
cout<<2<<endl;
} else {
cout<<0<<endl;
}
}
}