计算几何学 | 逆时针方向 | Counter-Clockwise | C/C++实现
问题描述
对于三个点p0、p1、p2,请按照下列情况进行输出:
p0、p1、p2成逆时针方向 COUNTER_CLOCKWISE
p0、p1、p2成顺时针方向 CLOCKWISE
p2、p0、p1依次排列在同一直线上 ONLINE_BACK
p0、p1、p2依次排列在同一直线上 ONLINE_FRONT
p2在线段p0p1上 ON_SEGMENT
输入:
…
第1行输入p0、p1的坐标。接下来给出q个p2的坐标用作问题。
输出:
根据各问题输出上述状态之一,每个问题占1行。
限制:
1 ≤ q ≤ 1000
-10000 ≤ ≤ 10000
p0、p1不是同一个点。
输入示例
0 0 2 0
5
-1 1
-1 -1
-1 0
0 0
3 0
输出示例
COUNTER_CLOCKWISE
CLOCKWISE
ONLINE_BACK
ON_SEGMENT
ONLINE_FRONT
讲解
向量a、b外积的方向与a、b所在平面垂直且满足右手螺旋定则,因此我们可以根据外积的方向判断向量a、b的位置关系。
(1)p2位于p0→p1的逆时针方向
(2)p2位于p0→p1的顺时针方向
(3)p2位于直线p0p1上,且顺序为p2→p0→p1
(4)p2位于直线p0p1上,且顺序为p0→p1→p2
(5)p2位于线段p0p1上,顺序为p0→p2→p1
设p0到p1的向量为a,p0到p2的向量为b,则各种情况的判断方法如下:
(1)外积的大小cross(a, b)为正时,可确定b在a的逆时针位置
(2)外积的大小cross(a, b)为负时,可确定b在a的顺时针位置
(3)(1)(2)都不符合时,表示p2位于直线p0p1上(不一定在线段p0p1上)。cosθ在θ大于90度或小于-90度时为负,因此a与b的内积dot(a, b)为负时,可确定p2位于线段p0p1后方,即顺序为p2→p0→p1。
(4)不符合(3)时,p2的位置为p0→p1→p2或p0→p2→p1。因此。如果b的大小大于a的,则可确定p2位于线段p0p1上。
(5)不符合(4)时,可确定p2位于线段p0p1上
下面的程序将三个点p0、p1、p2作为参数,返回点p2与向量p0→p1的位置关系。
逆时针方向CCW:
static const int COUNTER_CLOCKWISE = 1;
static const int CLOCKWISE = -1;
static const int ONLINE_BACK = 2;
static const int ONLINE_FRONT = -2;
static const int ON_SEGMENT = 0;
int ccw(Point p0, Point p1, Point p2) {
Vector a = p1 - p0;
Vector b = p2 - p0;
if( cross(a, b) > EPS ) return COUNTER_CLOCKWISE;
if( cross(a, b) < -EPS ) return CLOCKWISE;
if( dot(a, b) < -EPS ) return ONLINE_BACK;
if( a.norm() < b.norm() ) return ONLINE_FRONT;
return ON_SEGMENT;
}
AC代码如下
#include<stdio.h>
#include<iostream>
#include<cmath>
using namespace std;
#define EPS (1e-10)
#define equals(a, b) (fabs((a) - (b)) < EPS)
class Point {//Point类,点
public:
double x, y;
Point(double x = 0, double y = 0): x(x), y(y) {}
Point operator + (Point p) { return Point(x + p.x, y + p.y); }
Point operator - (Point p) { return Point(x - p.x, y - p.y); }
Point operator * (double a) { return Point(a * x, a * y); }
Point operator / (double a) { return Point(x / a, y / a); }
double abs() { return sqrt(norm()); }
double norm() { return x * x + y * y; }
bool operator < (const Point &p) const {
return x != p.x ? x < p.x : y < p.y;
}
bool operator == (const Point &p) const {
return fabs(x - p.x) < EPS && fabs(y - p.y) < EPS;
}
};
typedef Point Vector;//Vector类,向量
struct Segment{//Segment 线段
Point p1, p2;
};
double dot(Vector a, Vector b) {//内积
return a.x * b.x + a.y * b.y;
}
double cross(Vector a, Vector b) {//外积
return a.x*b.y - a.y*b.x;
}
static const int COUNTER_CLOCKWISE = 1;
static const int CLOCKWISE = -1;
static const int ONLINE_BACK = 2;
static const int ONLINE_FRONT = -2;
static const int ON_SEGMENT = 0;
int ccw(Point p0, Point p1, Point p2) {
Vector a = p1 - p0;
Vector b = p2 - p0;
if( cross(a, b) > EPS ) return COUNTER_CLOCKWISE;
if( cross(a, b) < -EPS ) return CLOCKWISE;
if( dot(a, b) < -EPS ) return ONLINE_BACK;
if( a.norm() < b.norm() ) return ONLINE_FRONT;
return ON_SEGMENT;
}
int main(){
Point p0, p1, p2;
cin>>p0.x>>p0.y>>p1.x>>p1.y;
int q;
cin>>q;
while(q--){
cin>>p2.x>>p2.y;
switch(ccw(p0, p1, p2)){
case 1: cout<<"COUNTER_CLOCKWISE"<<endl; break;
case -1: cout<<"CLOCKWISE"<<endl; break;
case 2: cout<<"ONLINE_BACK"<<endl; break;
case -2: cout<<"ONLINE_FRONT"<<endl; break;
case 0: cout<<"SEGMENT"<<endl; break;
}
}
}
注:以上本文未涉及代码的详细解释参见:计算几何学
上一篇: 2021-08-07
下一篇: 蓝桥杯——地宫取宝(记忆化搜索)