Moving Tables
Moving Tables
Time limit1000 ms
Memory limit32768 kB
The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.
The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.
For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.
Input
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.
Output
The output should contain the minimum time in minutes to complete the moving, one per line.
Sample Input
3
4
10 20
30 40
50 60
70 80
2
1 3
2 200
3
10 100
20 80
30 50
Sample Output
10
20
30
思路:
这个问题简化后就是200个位置里,最多的一个被经过几次
这一题分为了两面,观察可知,每一对数共用一道走廊
我们要的不是什么房间号,是走廊的位置号
所以先通过计算将两个房间号同步成一个数(即走廊位置)
yd[i].ks=(yd[i].ks+1)/2-1;
yd[i].js=(yd[i].js+1)/2-1;
只是这样当然还是wa;
还要考虑移动可能是双向的,也就是说要么先交换,要么增加判断条件
这里是先判断并交换
if(yd[i].ks>yd[i].js)
{
x=yd[i].ks;
yd[i].ks=yd[i].js;
yd[i].js=x;
}
完整代码
#include<bits/stdc++.h>
using namespace std;
struct abc
{
int ks,js;
}yd[200];
int main()
{
int i,j,jg,n,t,x;
cin>>t;
while(t--)
{
cin>>n;
for(i=0;i<n;i++)
{
cin>>yd[i].ks>>yd[i].js;
if(yd[i].ks>yd[i].js)
{
x=yd[i].ks;
yd[i].ks=yd[i].js;
yd[i].js=x;
}
yd[i].ks=(yd[i].ks+1)/2-1;
yd[i].js=(yd[i].js+1)/2-1;
}
int d[200]={0};
jg=0;
for(i=0;i<200;i++)
{
for(j=0;j<n;j++)
{
if(i>=yd[j].ks&&i<=yd[j].js) d[i]+=10;
}
if(jg<d[i])jg=d[i];
}
cout<<jg<<endl;
}
return 0;
}
下一篇: 9900k和8700k对比
推荐阅读
-
mysql8.0版本skip-grant-tables出现的新问题
-
mysql server is running with the --skip-grant-tables option
-
create table,show tables,describe table,DROP TABLE,ALTER TABLE ,怎么使用?
-
MySQL open_tables和opened_tables
-
How to Create Responsive Tables using CSS without