{A} + {B} HDU - 1412
程序员文章站
2022-03-23 13:19:43
...
给你两个集合,要求{A} + {B}.
注:同一个集合中不会有两个相同的元素.
Input
每组输入数据分为三行,第一行有两个数字n,m(0<n,m<=10000),分别表示集合A和集合B的元素个数.后两行分别表示集合A和集合B.每个元素为不超出int范围的整数,每个元素之间有一个空格隔开.
Output
针对每组数据输出一行数据,表示合并后的集合,要求从小到大输出,每个元素之间有一个空格隔开.
Sample Input
1 2
1
2 3
1 2
1
1 2
Sample Output
1 2 3
1 2
AC代码(本来以为是个水题很快就推了后来尽然因为多组输入卡住了心累)
代码一:(暴力)
Select Code
#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <cstring>
using namespace std;
int main()
{
int n, m, a[30000+10], i, f, x, j;
while(scanf("%d %d",&n,&m)!=EOF)
{
memset(a, 0, sizeof(a));
int k = n+m, h = 0;
for(i = 0; i<k; i++)
{
f = 1;
scanf("%d",&x);
for(j = 0; j<=h; j++)
{
if(a[j]==x)
{
f = 0;
break;
}
}
if(f==1)
a[h++] = x;
}
sort(a, a+h);
for(i = 0; i<h; i++)
{
printf("%d%c",a[i],i==h-1?'\n':' ');
}
}
return 0;
}
代码二:(查重简单一点)
Select Code
#include<stdio.h>
#include <stdio.h>
#include <algorithm>
#include <math.h>
#include <string.h>
using namespace std;
int main()
{
int a[30000+10], i, n, m;
while(scanf("%d %d",&n,&m)!=EOF)
{
for(i = 0; i<n+m; i++)
{
scanf("%d",&a[i]);
}
sort(a, a+n+m);
printf("%d",a[0]);
for(i = 1; i<n+m; i++)
{
if(a[i]!=a[i-1])
{
printf(" %d",a[i]);
}
}
printf("\n");
}
return 0;
}
上一篇: 为什么会有人掏380万元买一个表情包?
推荐阅读
-
Codeforces Round #261 (Div. 2)B. Pashmak and Flowers(容易)
-
ShopNC B2B2C多用户商城网站系统源码,shopncb2b2c
-
2020.4.29省选模拟赛 A B C(容斥、图论计数DP、树套树+set)
-
牛客OI周赛14-提高组(A 容斥 计数,B状压dp)
-
静态文件服务器A和web应用服务器B分开,怎么样在B服务器上传的图片,上传到静态文件服务器应用是PHP写的?
-
b站33卡是什么 b站33卡资费详情及申请地址介绍
-
Problem B: 残缺的棋盘
-
暑假训练赛5--Problem B/zcmu1639: 残缺的棋盘
-
POJ 2312 B - Battle City【BFS】
-
【HZNU Summer training】CF-129B Students and Shoelaces (拓扑排序)