欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

{A} + {B} HDU - 1412

程序员文章站 2022-03-23 13:19:43
...

 

给你两个集合,要求{A} + {B}. 
注:同一个集合中不会有两个相同的元素.

Input

每组输入数据分为三行,第一行有两个数字n,m(0<n,m<=10000),分别表示集合A和集合B的元素个数.后两行分别表示集合A和集合B.每个元素为不超出int范围的整数,每个元素之间有一个空格隔开.

Output

针对每组数据输出一行数据,表示合并后的集合,要求从小到大输出,每个元素之间有一个空格隔开.

Sample Input

1 2
1
2 3
1 2
1
1 2

Sample Output

1 2 3
1 2

AC代码(本来以为是个水题很快就推了后来尽然因为多组输入卡住了心累)

代码一:(暴力)

Select Code

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <cstring>
using namespace std;

int main()
{
    int n, m, a[30000+10], i, f, x, j;
    while(scanf("%d %d",&n,&m)!=EOF)
    {
         memset(a, 0, sizeof(a));
        int k = n+m, h = 0;
        for(i = 0; i<k; i++)
        {
            f = 1;
            scanf("%d",&x);
            for(j = 0; j<=h; j++)
            {
                if(a[j]==x)
                {
                    f = 0;
                    break;
                }
            }
            if(f==1)
                a[h++] = x;
        }
        sort(a, a+h);
        for(i = 0; i<h; i++)
        {
            printf("%d%c",a[i],i==h-1?'\n':' ');
        }
    }
    return 0;
}

代码二:(查重简单一点)

 Select Code

#include<stdio.h>
#include <stdio.h>
#include <algorithm>
#include <math.h>
#include <string.h>
using namespace std;

int main()
{
    int a[30000+10], i, n, m;
    while(scanf("%d %d",&n,&m)!=EOF)
    {
        for(i = 0; i<n+m; i++)
        {
            scanf("%d",&a[i]);
        }
        sort(a, a+n+m);
        printf("%d",a[0]);
        for(i = 1; i<n+m; i++)
        {
            if(a[i]!=a[i-1])
            {
                printf(" %d",a[i]);
            }
        }
        printf("\n");
    }
    return 0;
}