欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

HDU 1412 {A} + {B}

程序员文章站 2022-03-23 13:21:25
...

{A} + {B}

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 31373    Accepted Submission(s): 12596


 

Problem Description

给你两个集合,要求{A} + {B}.
注:同一个集合中不会有两个相同的元素.

 

 

Input

每组输入数据分为三行,第一行有两个数字n,m(0<n,m<=10000),分别表示集合A和集合B的元素个数.后两行分别表示集合A和集合B.每个元素为不超出int范围的整数,每个元素之间有一个空格隔开.

 

 

Output

针对每组数据输出一行数据,表示合并后的集合,要求从小到大输出,每个元素之间有一个空格隔开.

 

 

Sample Input

 

1 2

1

2 3

1 2

1

1 2

 

 

Sample Output

 

1 2 3

1 2

 

 

#include<iostream>
#include<set>
using namespace std;
int main(void){
	
	int n,m;
	while( scanf("%d%d",&n,&m)!=EOF){
		
		int a;
		set<int> s;
		for( int i=1;i<=n+m;i++){ 
		     scanf("%d",&a);
             s.insert( a ); 
		 }
		set<int>::iterator it;
		for( it = s.begin();it!=s.end();it++){ 
		     if( it!=s.begin() )
		         cout<<" "; 
		     cout<<*it;
		 }
		 
		cout<<endl;     
	}
	
	
	return 0;
}

 

相关标签: set