STL中的string
string相关的部分知识
string的定义
string str;
//定义并初始化
string str="abcd";
string数组的定义
const int maxn=1001;
string str[maxn];
string的加法
可以将两个string直接拼接起来
str3=str1+str2;//将str1和str2拼接,赋值给str3
str1+=str2;//将str2直接拼接到str1上
string的比较
直接使用==、!=、<=、<、>、>=比较大小,比较规则是字典序
string str1="aa",str2="aaa";
if(str1<str2)printf("ok");//输出了ok
string的长度
使用size()和length()函数,返回存放的字符数
string str="abcdxyz";
printf("%d %d\n",str.length(),str.length());
string中元素的删除
erase()有两种用法:删除单个元素、删除一个区间内的所有元素
这里只讲删除单个元素
erase(it)用于删除单个元素,it为需要删除的元素的迭代器
应用实例
1038 Recover the Smallest Number
Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.
Input Specification:
Each input file contains one test case. Each case gives a positive integer N (≤104) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print the smallest number in one line. Notice that the first digit must not be zero.
Sample Input:
5 32 321 3214 0229 87
Sample Output:
22932132143287
#include <iostream>
#include <string>
#include <algorithm>
using namespace std;
const int maxn=10010;
string str[maxn];
bool cmp(string a,string b){
return a+b<b+a;
}
int main(){
int n;
cin>>n;
for(int i=0;i<n;i++)
cin>>str[i];
sort(str,str+n,cmp);
string ans;
for(int i=0;i<n;i++)
ans+=str[i];
while(ans.size()!=0&&ans[0]=='0')
ans.erase(ans.begin());
if(ans.size()==0)cout<<0;
else
cout<<ans;
}
上一篇: 商品分类管理模块基本完成
下一篇: C++STL中的set用法