Square Coins(hdu 1398) (母函数)
Square Coins
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14322 Accepted Submission(s): 9845
Problem Description
People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are available in Silverland.
There are four combinations of coins to pay ten credits:
ten 1-credit coins,
one 4-credit coin and six 1-credit coins,
two 4-credit coins and two 1-credit coins, and
one 9-credit coin and one 1-credit coin.
Your mission is to count the number of ways to pay a given amount using coins of Silverland.
Input
The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.
Output
For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output.
Sample Input
2 10 30 0
Sample Output
1 4 27
Source
还是典型的母函数的问法,改改板子就能过.这个题目变成了平方.
我们还是用x表示coin,可以构造这样一个母函数:(1+x+x^2+x^3.....)(1+x^4+x^8+...)(1+x^9+x^18+.....).....
注意到这里是的指数和第i个表达式是平方的关系,所以我们将板子对应的改成i*i<=n,k+=i*i即可。---转自博客
#include<bits/stdc++.h>
using namespace std;
int c1[305],c2[305];
int main()
{
int n;
while(~scanf("%d",&n)&&n)
{
for(int i = 0; i <= n; i++)
{
c1[i] = 1;
c2[i] = 0;
}
for(int i = 2; i*i <= n; i++)
{
for(int j = 0; j <= n; j++)
{
for(int k = 0; k + j <= n; k += i*i)
{
c2[k+j] += c1[j];
}
}
for(int j = 0; j <= n; j++)
{
c1[j] = c2[j];
c2[j] = 0;
}
}
printf("%d\n",c1[n]);
}
return 0;
}