欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

B - {A} + {B} HDU - 1412

程序员文章站 2022-03-01 23:18:03
...

给你两个集合,要求{A} + {B}.
注:同一个集合中不会有两个相同的元素.
Input
每组输入数据分为三行,第一行有两个数字n,m(0<n,m<=10000),分别表示集合A和集合B的元素个数.后两行分别表示集合A和集合B.每个元素为不超出int范围的整数,每个元素之间有一个空格隔开.
Output
针对每组数据输出一行数据,表示合并后的集合,要求从小到大输出,每个元素之间有一个空格隔开.

Sample Input
1 2
1
2 3
1 2
1
1 2
Sample Output
1 2 3
1 2

一道用来复习stl的题目,用set做就可以很简单。

/*set函数用法
set<int>s;
s.insert(x) 插入元素x
s.erase(x) 删除指定元素;
s.clear()清空s
s.size() 返回长度
s.find(x) 查找x的位置
*/

#include <iostream>
#include<stdio.h>
#include<string.h>
#include<cmath>
#include<algorithm>
#include<set>
using namespace std;

int main()
{
    int n,m;
    set<int> s;
    set<int>::iterator it;
    while(scanf("%d %d",&n,&m)!=EOF)
    {
        for(int i=0;i<n+m;i++)
        {
            int a;
            scanf("%d",&a);
            s.insert(a);
        }
        for(it=s.begin();it!=s.end();it++)
        {
            if(it==s.begin())
                printf("%d",*it);
            else
                printf(" %d",*it);
        }
        s.clear();
        printf("\n");
    }
}

相关标签: stl