顺序表--删除重复元素
程序员文章站
2022-03-15 09:48:39
...
数据结构上机测试1:顺序表的应用
在长度为n(n<1000)的顺序表中可能存在着一些值相同的“多余”数据元素(类型为整型),编写一个程序将“多余”的数据元素从顺序表中删除,使该表由一个“非纯表”(值相同的元素在表中可能有多个)变成一个“纯表”(值相同的元素在表中只能有一个)。
Input
第一行输入表的长度n;
第二行依次输入顺序表初始存放的n个元素值。
Output
第一行输出完成多余元素删除以后顺序表的元素个数;
第二行依次输出完成删除后的顺序表元素。
Sample Input
12
5 2 5 3 3 4 2 5 7 5 4 3
Sample Output
5
5 2 3 4 7
#include<stdio.h>
#include<iostream>
#include<stdlib.h>
using namespace std;
#define MAXSIZE 1000
typedef int Elemtype;
typedef struct
{
Elemtype data[MAXSIZE];
int length;
}SqList;
int main()
{
SqList *L,*S;
int newlength = 1;
int j,flat;
L=(SqList *)malloc(sizeof (SqList ));
S=(SqList *)malloc(sizeof (SqList ));
int N;
cin >> N;
for( int i=0; i<N; i++)
{
cin >> L->data[i];
}
S->data[0] = L->data[0];
for( int i=1; i<N; i++)
{
for( j = 0; j < newlength; j++)
{
if(S->data[j] == L->data[i])
break;
}
if(j==newlength)
{
S->data[j] = L->data[i];
newlength ++;
}
}
cout << newlength << endl;
for( int i = 0; i < newlength-1; i++)
cout << S->data[i] <<' ';
cout << S->data[newlength-1];
return 0;
}