欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

习题3-1 得分

程序员文章站 2022-03-14 19:37:38
...

There is an objective test result such as “OOXXOXXOOO”. An ‘O’ means a correct answer of a problem and an ‘X’ means a wrong answer. The score of each problem of this test is calculated by itself and its just previous consecutive ‘O’s only when the answer is correct. For example, the score of the 10th problem is 3 that is obtained by itself and its two previous consecutive ‘O’s. Therefore, the score of “OOXXOXXOOO” is 10 which is calculated by “1+2+0+0+1+0+0+1+2+3”. You are to write a program calculating the scores of test results.

Input

Your program is to read from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case starts with a line containing a string composed by ‘O’ and ‘X’ and the length of the string is more than 0 and less than 80. There is no spaces between ‘O’ and ‘X’.

Output

Your program is to write to standard output. Print exactly one line for each test case. The line is to contain the score of the test case.

Sample Input

5

OOXXOXXOOO

OOXXOOXXOO

OXOXOXOXOXOXOX

OOOOOOOOOO

OOOOXOOOOXOOOOX

Sample Output

10

9

7

55

30

 

#include <iostream>
#include <string.h>
const int maxn = 50;
char s[maxn];
int main()
{
	int score, count = 0;
	int N,len;
	scanf("%d\n", &N);
	while(N--) {
		scanf("%s", s);
		count = 0;
		score = 0;
		len = strlen(s);
		for (int j = 0; j < len; j++) {
			
			if (s[j] == 'O') {
				count++;
				score += count;
			}
			else count = 0;
		}
		printf("%d\n", score);
	}
	return 0;
}