【模拟】Parity
描述
A bit string has odd parity if the number of 1’s is odd. A bit string has even parity if the number of 1’s is even.Zero is considered to be an even number, so a bit string with no 1’s has even parity. Note that the number of
0’s does not affect the parity of a bit string.
输入
The input consists of one or more strings, each on a line by itself, followed by a line containing only “#” that signals the end of the input. Each string contains 1~31 bits followed by either a lowercase letter ‘e’ or a lowercase letter ‘o’.
输出
Each line of output must look just like the corresponding line of input, except that the letter at the end is replaced by the correct bit so that the entire bit string has even parity (if the letter was ‘e’) or odd parity (if the letter was ‘o’).
样例输入
101e
010010o
1e
000e
110100101o
样例输出
1010
0100101
11
0000
1101001010
题目来源
Mid-Central USA 2008
分析:
不算难的模拟,根据奇偶性来修改字符串。
代码:
#include<bits/stdc++.h>
using namespace std;
int main()
{
string s;
int t;
while(cin>>s)
{
t=0;
if (s[0]=='#') break;
int l=s.length();
for (int i=0;i<l;i++)
{
if (s[i]=='1') t++;//统计1的个数来判断奇偶
}
if (t%2==0)//偶数
{
if (s[l-1]=='e')
s[l-1]='0';
if (s[l-1]=='o')
s[l-1]='1';
}
else
{
if (s[l-1]=='e')
s[l-1]='1';
else
if (s[l-1]=='o')
s[l-1]='0';
}
cout<<s<<endl;
}
return 0;
}