欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

Java——十进制转二进制

程序员文章站 2022-07-15 09:36:40
...

Description

编写代码,要求:输入参数是一个正整数,输出该整数所对应的二进制数对应的字符串。

Input

正整数

Output

输入的正整数对应的二进制字符串“1001”

Sample Input

9

Sample Output

1001
import java.util.*;
public class Main{
	
	public static void main(String argc[])
	{
		Scanner scan = new Scanner(System.in);
		int num = scan.nextInt();
		String s = "";
		while(num > 0)
		{
			s += String.valueOf(num % 2);
			num = num /2;
		}
		
		for(int i = s.length()-1; i >= 0 ; i--)
		{
			System.out.print(s.charAt(i));
		}
	}
}