1242 二进制整数转十进制
程序员文章站
2022-07-15 09:33:35
...
Description
给出一个二进制的非负整数x,x<232,把它转换成十进制数输出。
Input
输入为多行,每行一个二进制非负整数x。
Output
每行输出x对应的十进制数值。
Sample Input
0
1
01
10
11
100001
1111111111111111
Sample Output
0
1
1
2
3
33
65535
HINT
注意数据范围!!!
Append Code
#include <stdio.h>
#include <string.h>
#include <math.h>
int main()
{
long long int m,n,i,j,sum;
char a[33]={0};
while(scanf("%s",a)!=EOF)
{
sum=0;
m=strlen(a);
for(i=m-1;i>=0;i--)
{
sum+=(a[i]-'0')*(long long int)pow(2,m-1-i);
}
printf("%lld\n",sum);//注意!!换为%d wa67%
}
return 0;
}