Dating with girls(2)
If you have solved the problem Dating with girls(1).I think you can solve this problem too.This problem is also about dating with girls. Now you are in a maze and the girl you want to date with is also in the maze.If you can find the girl, then you can date with the girl.Else the girl will date with other boys. What a pity!
The Maze is very strange. There are many stones in the maze. The stone will disappear at time t if t is a multiple of k(2<= k <= 10), on the other time , stones will be still there.
There are only ‘.’ or ‘#’, ’Y’, ’G’ on the map of the maze. ’.’ indicates the blank which you can move on, ‘#’ indicates stones. ’Y’ indicates the your location. ‘G’ indicates the girl's location . There is only one ‘Y’ and one ‘G’. Every seconds you can move left, right, up or down.
Input
The first line contain an integer T. Then T cases followed. Each case begins with three integers r and c (1 <= r , c <= 100), and k(2 <=k <= 10).
The next r line is the map’s description.
Output
For each cases, if you can find the girl, output the least time in seconds, else output "Please give me another chance!".
Sample Input
1 6 6 2 ...Y.. ...#.. .#.... ...#.. ...#.. ..#G#.
Sample Output
7
题意:给你一个数T,表示有T组测试示例,接下来时r,c,k,表示迷宫的大小为r行c列,这个迷宫是非常奇怪的,迷宫里有很多石头。这些石头会在t时刻消失,t的定义是k的倍数,在其他时候石头是依然存在的..是你可以直接走的到地方,#表示石头,Y表示你的初始位子,G表示妹纸,保证只有一个Y和一个G,每一秒你可以向左走,向右走,向上走,或者向下走。
题解:有可以重复走的地方,要开三维数组,一二维表示坐标,三维表示步数。
#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
struct node
{
int x,y,output;
}now,nex;
int fx[4]={0,0,1,-1};
int fy[4]={1,-1,0,0};
char a[105][105];
int vis[105][105][12];
int n,m,k;
void bfs(int x,int y)
{
memset(vis,0,sizeof(vis));
now.x=x;
now.y=y;
now.output=0;
vis[x][y][0]=1;
queue<node>s;
s.push(now);
while(!s.empty())
{
now=s.front();
if(a[now.x][now.y]=='G')
{
printf("%d\n",now.output);
return ;
}
s.pop();
for(int i=0;i<4;i++)
{
nex.x=now.x+fx[i];
nex.y=now.y+fy[i];
nex.output=now.output+1;
if(nex.x>=0&&nex.x<n&&nex.y>=0&&nex.y<m&&vis[nex.x][nex.y][nex.output%k]==0)
{
if(a[nex.x][nex.y]=='.'||a[nex.x][nex.y]=='G'||a[nex.x][nex.y]=='Y')
{
vis[nex.x][nex.y][nex.output%k]=1;
s.push(nex);
}
if(a[nex.x][nex.y]=='#'&&nex.output%k==0)
{
vis[nex.x][nex.y][nex.output%k]=1;
s.push(nex);
}
}
}
}
printf("Please give me another chance!\n");
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int sx,sy;
scanf("%d%d%d",&n,&m,&k);
for(int i=0;i<n;i++)
{
scanf("%s",a[i]);
for(int j=0;j<m;j++)
{
if(a[i][j]=='Y')
{
sx=i;
sy=j;
}
}
}
bfs(sx,sy);
}
return 0;
}
推荐阅读