欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

A problem is easy

程序员文章站 2022-07-14 21:34:18
...

A problem is easy

时间限制:1000 ms  |  内存限制:65535 KB
难度:3
描述
When Teddy was a child , he was always thinking about some simple math problems ,such as “What it’s 1 cup of water plus 1 pile of dough ..” , “100 yuan buy 100 pig” .etc..
A problem is easy

One day Teddy met a old man in his dream , in that dream the man whose name was“RuLai” gave Teddy a problem :

Given an N , can you calculate how many ways to write N as i * j + i + j (0 < i <= j) ?

Teddy found the answer when N was less than 10…but if N get bigger , he found it was too difficult for him to solve.
Well , you clever ACMers ,could you help little Teddy to solve this problem and let him have a good dream ?
输入
The first line contain a T(T <= 2000) . followed by T lines ,each line contain an integer N (0<=N <= 10^11).
输出
For each case, output the number of ways in one line
样例输入
2
1
3
样例输出
0
1

import java.util.Scanner;


public class Main {

	public static void main(String[] args) {
		Scanner scanner=new Scanner(System.in);
		int times=scanner.nextInt();
		while(times--!=0)
		{
			int number=scanner.nextInt();
			int count=0;
			for(int i=1;(i+1)*(i+1)<=(number+1);i++)
			{
				if((number+1)%(i+1)==0)
					count++;
			}
			System.out.println(count);
		}
	}

}