欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

poj1936 All in All

程序员文章站 2022-03-13 22:43:26
...
All in All
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 26236   Accepted: 10638

Description

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.

Input

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.

Output

For each test case output "Yes", if s is a subsequence of t,otherwise output "No".

Sample Input

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output

Yes
No
Yes
No

Source

 
#include<cstdio>
#include<cstring>
using namespace std;

#define MAXN 100000+5
char s[MAXN],str[MAXN];

int main(){
	int i,j,len1,len2;
	while(~scanf("%s%s",s,str)){
		len1=strlen(s);
		len2=strlen(str);
		i=j=0;
		while(i<len2&&j<len1){
			if(s[j]==str[i]){
				i+=1;
				j+=1;
			}
			else
				i+=1;
		}
		if(j==len1)
			printf("Yes\n");
		else
			printf("No\n");
	}
	return 0;
}