欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

BST(树状数组原理)

程序员文章站 2022-07-13 21:22:58
...
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 10615   Accepted: 6497

Description

Consider an infinite full binary search tree (see the figure below), the numbers in the nodes are 1, 2, 3, .... In a subtree whose root node is X, we can get the minimum number in this subtree by repeating going down the left node until the last level, and we can also find the maximum number by going down the right node. Now you are given some queries as "What are the minimum and maximum numbers in the subtree whose root node is X?" Please try to find answers for there queries. 
BST(树状数组原理)

Input

In the input, the first line contains an integer N, which represents the number of queries. In the next N lines, each contains a number representing a subtree with root number X (1 <= X <= 231 - 1).

Output

There are N lines in total, the i-th of which contains the answer for the i-th query.

Sample Input

2
8
10

Sample Output

1 15
9 11

Source

POJ Monthly,Minkerui
看来还得对树状数组理解才行,这道题目就是个例子。。。看图对比一下就知道了!!!
BST(树状数组原理)

这样我们得出答案是x - lowbit(x) + 1 , x + lowbit(x) - 1

代码:

#include<iostream>
#include<cstdio>
#define ll long long
using namespace std;
int n;

ll lowbit(ll x)
{
    return x&-x;
}

ll minmum(ll x)
{
    return x - lowbit(x) + 1;
}

ll maxmum(ll x)
{
    return x + lowbit(x) - 1;
}

int main()
{
    ll x;
    scanf("%d", &n);
    while(n--) {
        scanf("%lld", &x);
        printf("%lld %lld\n", minmum(x), maxmum(x));
    }
    return 0;
}