HDU-1698 Just a Hook
Just a Hook
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 42993 Accepted Submission(s): 20670
Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.
Now Pudge wants to do some operations on the hook.
Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:
For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.
Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
Sample Input
1
10 2
1 5 2
5 9 3
Sample Output
Case 1: The total value of the hook is 24.
线段树更新区间问题
#include <stdio.h>
#define MAXN 100000
struct segNode{
int val;
int l,r;
} tr[MAXN<<2];
void build( int id , int s , int e ){
tr[id].val = 1;
tr[id].l = s;
tr[id].r = e;
if( s==e )
return ;
int mid = ( s+e )/2;
build( id*2,s,mid );
build( id*2+1,mid+1,e );
}
void updata( int id , int s , int e , int col ){
if( tr[id].val==col )
return ;
if( tr[id].l==s && tr[id].r==e ){
tr[id].val = col;
return ;
}
if( tr[id].val!=-1 ){
tr[id*2].val = tr[id*2+1].val = tr[id].val;
tr[id].val = -1;
}
int mid = ( tr[id].l + tr[id].r ) / 2;
if( mid>=e )
updata( id*2,s,e,col );
else if( mid<s )
updata( id*2+1,s,e,col );
else{
updata( id*2,s,mid,col );
updata( id*2+1,mid+1,e,col );
}
}
int query( int id , int l , int r ){
if( tr[id].val==-1 )
return query( id*2,l,r ) + query( id*2+1,l,r );
return ( tr[id].r - tr[id].l + 1 ) * tr[id].val;
}
int main(){
int t,n,q;
scanf( "%d",&t );
for( int k=1 ; k<=t ; k++ ){
scanf( "%d%d",&n,&q );
build( 1,1,n );
int s,e,v;
for( int i=1 ; i<=q ; i++ ){
scanf( "%d%d%d",&s,&e,&v );
updata( 1,s,e,v );
}
printf("Case %d: The total value of the hook is %d.\n",k,query( 1,1,n ) );
}
}
推荐阅读
-
python利用hook技术破解https的实例代码
-
php中钩子(hook)的原理与简单应用demo示例
-
关于为什么使用React新特性Hook的一些实践与浅见
-
Android逆向之旅---Native层的Hook神器Cydia Substrate使用详解
-
CI框架中通过hook的方式实现简单的权限控制
-
基于桥的全量方法Hook方案 - 探究苹果主线程检查实现
-
关于如何使用xposed来hook某支付软件
-
2019 Multi-University Training Contest 2: 1010 Just Skip The Problem 自闭记
-
tensorflow estimator 使用hook实现finetune方式
-
win7 下 VisualSVN Server post-commit hook failed (exit code 1) with output解决方