HDU1698Just a Hook
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.
Now Pudge wants to do some operations on the hook.
Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:
For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.
Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
Sample Input
1
10
2
1 5 2
5 9 3
Sample Output
Case 1: The total value of the hook is 24.
区间染色问题
#include<iostream>
#include<cstring>
#define N 100010*4
#define lson(x) (x<<1)
#define rson(x) (x<<1|1)
using namespace std;
typedef long long LL;
struct node
{
int l;
int r;
int f;
LL money;
}tree[N];
void pushup(int pos)
{
tree[pos].money=tree[lson(pos)].money+tree[rson(pos)].money;
}
void pushdown(int pos)
{
tree[lson(pos)].f=tree[pos].f;
tree[rson(pos)].f=tree[pos].f;
tree[lson(pos)].money=(tree[lson(pos)].r-tree[lson(pos)].l+1)*tree[pos].f;
tree[rson(pos)].money=(tree[rson(pos)].r-tree[rson(pos)].l+1)*tree[pos].f;
tree[pos].f=0;
}
void build(int pos,int ll,int rr)
{
tree[pos].l=ll;
tree[pos].r=rr;
tree[pos].f=0;
if(ll==rr)
{
tree[pos].money=1;
return ;
}
int mid=(ll+rr)>>1;
build(lson(pos),ll,mid);
build(rson(pos),mid+1,rr);
pushup(pos);
}
void update(int pos,int ll,int rr,LL zz)
{
if(ll<=tree[pos].l&&tree[pos].r<=rr)
{
tree[pos].money=(tree[pos].r-tree[pos].l+1)*zz;
tree[pos].f=zz;
return ;
}
if(tree[pos].f)
pushdown(pos);
int mid=(tree[pos].l+tree[pos].r)>>1;
if(ll<=mid)
update(lson(pos),ll,rr,zz);
if(rr>mid)
update(rson(pos),ll,rr,zz);
pushup(pos);
}
int main()
{
int t,n,m,cnt=0;
//freopen("in.txt","r",stdin);
scanf("%d\n",&t);
while(t--)
{
cnt++;
scanf("%d",&n);
build(1,1,n);
scanf("%d",&m);
int x,y;
LL z;
for(int i=0;i<m;i++)
{
scanf("%d %d %lld",&x,&y,&z);
update(1,x,y,z);
}
printf("Case %d: The total value of the hook is %lld.\n",cnt,tree[1].money);
}
return 0;
}
上一篇: HDU 1698 Just a Hook
推荐阅读
-
关于为什么使用React新特性Hook的一些实践与浅见
-
Android逆向之旅---Native层的Hook神器Cydia Substrate使用详解
-
CI框架中通过hook的方式实现简单的权限控制
-
基于桥的全量方法Hook方案 - 探究苹果主线程检查实现
-
关于如何使用xposed来hook某支付软件
-
tensorflow estimator 使用hook实现finetune方式
-
win7 下 VisualSVN Server post-commit hook failed (exit code 1) with output解决方
-
iOS开发中实现hook消息机制的方法探究
-
hdu1698 Just a Hook(线段树)
-
React Hook用法示例详解(6个常见hook)