欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

uva 1584 Circular Sequence

程序员文章站 2022-03-13 20:47:59
...

原题:
Some DNA sequences exist in circular forms as in the following figure, which shows a circular sequence “CGAGTCAGCT”, that is, the last symbol “T” in “CGAGTCAGCT” is connected to the first symbol “C”. We always read a circular sequence in the clockwise direction.Since it is not easy to store a circular sequence in a computer as it is, we decided to store it as a linear sequence.However, there can be many linear sequences that are obtained from a circular sequence by cutting any place of the
circular sequence. Hence, we also decided to store the linear sequence that is lexicographically smallest among all linear
sequences that can be obtained from a circular sequence.Your task is to find the lexicographically smallest sequence
from a given circular sequence. For the example in the figure,the lexicographically smallest sequence is “AGCTCGAGTC”. If there are two or more linear sequences thatare lexicographically smallest, you are to find any one of them (in fact, they are the same).
uva 1584 Circular Sequence

Input
The input consists of T test cases. The number of test cases T is given on the first line of the input file. Each test case takes one line containing a circular sequence that is written as an arbitrary linear sequence. Since the circular sequences are DNA sequences, only four symbols, ‘A’, ‘C’, ‘G’ and ‘T’, are allowed. Each sequence has length at least 2 and at most 100.
Output
Print exactly one line for each test case. The line is to contain the lexicographically smallest sequence for the test case.
Sample Input
2
CGAGTCAGCT
CTCC
Sample Output
AGCTCGAGTC
CCCT

中文:
给你一个环形字符串,字符串仅包含AGCT,可以从任意位置作为开头,问你最后得到的最小字典序的字符串是什么。

#include <bits/stdc++.h>

using namespace std;
typedef long long ll;
string s;

string solve(int ind)
{
    string tmp(s.begin()+ind,s.end());
    for(int i=0;i<ind;i++)
        tmp+=s[i];
    return tmp;
}

int main()
{
    ios::sync_with_stdio(false);
    int t;
    cin>>t;
    while(t--)
    {
        cin>>s;
        vector<int> v[4];
        for(int i=0;i<s.size();i++)
        {
            if(s[i]=='A')
                v[0].push_back(i);
            if(s[i]=='C')
                v[1].push_back(i);
            if(s[i]=='G')
                v[2].push_back(i);
            if(s[i]=='T')
                v[3].push_back(i);
        }
        int res=-1;
        string ans,tmp;
        for(int i=0;i<4;i++)
        {
            for(int j=0;j<v[i].size();j++)
            {
                tmp=solve(v[i][j]);
                if(ans.empty()||tmp<ans)
                    ans=tmp;
                if(ans.size()!=0)
                    res=0;
            }
            if(res!=-1)
            {
                cout<<ans<<endl;
                break;
            }
        }
    }
    return 0;
}

解答:

紫书上的入门题~

字母只有AGCT四个,如果存在字母A,那么一定是字母A开头的字典序最小。

所以把这四个字母的下标记下来,按照ACGT的顺序去查找字符串,只要找到就是最小字典序

相关标签: uva