动态规划——最长公共子序列
程序员文章站
2022-07-12 08:55:20
...
Description
咱们就不拐弯抹角了,如题,需要你做的就是写一个程序,得出最长公共子序列。
tip:最长公共子序列也称作最长公共子串(不要求连续),英文缩写为LCS(Longest Common Subsequence)。
其定义是,一个序列 S ,如果分别是两个或多个已知序列的子序列,且是所有符合此条件序列中最长的,则 S 称为已知序列的最长公共子序列。
Input
第一行给出一个整数N(0<N<100)表示待测数据组数
接下来每组数据两行,分别为待测的两组字符串。每个字符串长度不大于1000.
Output
每组测试数据输出一个整数,表示最长公共子序列长度。每组结果占一行。
Sample Input
2
asdf
adfsd
123abc
abc123abc
Sample Output
3
6
题解:最长公共子序列
#include<stdio.h>
#include<math.h>
#include<string.h>
int max(int a,int b)
{
if(a>b)return a;
else return b;
}
int main()
{
int t;
char a[1000],b[1000];
int c[1010][1010];
scanf("%d",&t);
while(t--)
{
scanf("%s%s",&a,&b);
memset(c,0,sizeof(c));
for(int i=1;i<=strlen(a);i++){
for(int j=1;j<=strlen(b);j++)
if(a[i-1]==b[j-1])c[i][j]=c[i-1][j-1]+1;
else c[i][j]=max(c[i][j-1],c[i-1][j]);
}
printf("%d\n",c[strlen(a)][strlen(b)]);
}
return 0;
}
上一篇: LeetCode刷题之392.判断子序列
下一篇: 最长公共子序列动态规划