Edge
程序员文章站
2022-07-01 17:36:14
...
Problem Description
For products that are wrapped in small packings it is necessary that the sheet of paper containing the directions for use is folded until its size becomes small enough. We assume that a sheet of paper is rectangular and only folded along lines parallel to its
initially shorter edge. The act of folding along such a line, however, can be performed in two directions: either the surface on the top of the sheet is brought together, or the surface on its bottom. In both cases the two parts of the rectangle that are separated
by the folding line are laid together neatly and we ignore any differences in thickness of the resulting folded sheet.
After several such folding steps have been performed we may unfold the sheet again and take a look at its longer edge holding the sheet so that it appears as a one-dimensional curve, actually a concatenation of line segments. If we move along this curve in a fixed direction we can classify every place where the sheet was folded as either type A meaning a clockwise turn or type V meaning a counter-clockwise turn. Given such a sequence of classifications, produce a drawing of the longer edge of the sheet assuming 90 degree turns at equidistant places.
After several such folding steps have been performed we may unfold the sheet again and take a look at its longer edge holding the sheet so that it appears as a one-dimensional curve, actually a concatenation of line segments. If we move along this curve in a fixed direction we can classify every place where the sheet was folded as either type A meaning a clockwise turn or type V meaning a counter-clockwise turn. Given such a sequence of classifications, produce a drawing of the longer edge of the sheet assuming 90 degree turns at equidistant places.
Input
The input contains several test cases, each on a separate line. Each line contains a nonempty string of characters A and V describing the longer edge of the sheet. You may assume that the length of the string is less than 200. The input file terminates immediately
after the last test case.
Output
For each test case generate a PostScript drawing of the edge with commands placed on separate lines. Start every drawing at the coordinates (300, 420) with the command "300 420 moveto". The first turn occurs at (310, 420) using the command "310 420 lineto".
Continue with clockwise or counter-clockwise turns according to the input string, using a sequence of "x y lineto" commands with the appropriate coordinates. The turning points are separated at a distance of 10 units. Do not forget the end point of the edge
and finish each test case by the commands stroke and showpage.
You may display such drawings with the gv PostScript interpreter, optionally after a conversion using the ps2ps utility.
You may display such drawings with the gv PostScript interpreter, optionally after a conversion using the ps2ps utility.
Sample Input
V AVV
Sample Output
300 420 moveto
310 420 lineto
310 430 lineto
stroke
showpage
300 420 moveto
310 420 lineto
310 410 lineto
320 410 lineto
320 420 lineto
stroke
showpage
emmm一道有点讲故事的感觉的题目 其实就是一个路径题..
主角从 300 420 面朝X正半轴开始运动
输入A右拐 V左拐 每次先走10再转弯..
就是路径设置 用switch解决
注意样例 可以看出一开始就走了10 其实也就是从310 420面朝X正半轴出发
#include<stdio.h>
#include<string.h>
int main()
{
int x,y;
char p;
char a[999];
while(scanf("%s",a)!=EOF)
{
x=300;
y=420;
p='e';
printf("%d %d moveto\n",x,y);
int i;
x+=10;
printf("%d %d lineto\n",x,y);
for(i=0;i<strlen(a);i++)
{
switch(p)
{
case 'n':
if(a[i]=='A') {p='e';x+=10;}
else {p='w';x-=10;}
break;
case 'w':
if(a[i]=='A') {p='n';y+=10;}
else {p='s';y-=10;}
break;
case 's':
if(a[i]=='A') {p='w';x-=10;}
else {p='e';x+=10;}
break;
case 'e':
if(a[i]=='A') {p='s';y-=10;}
else {p='n';y+=10;}
break;
}
printf("%d %d lineto\n",x,y);
}
printf("stroke\nshowpage\n");
}
return 0;
}
推荐阅读
-
Win10系统Edge浏览器已支持Brotli压缩算法
-
Windows 10全新浏览器终于有名字了:Microsoft Edge
-
微软Edge浏览器上手体验:界面简洁功能按钮很实用
-
微软斯巴达浏览器命名Edge 可兼容Chrome和Firefox插件
-
微软win10 10074 Edge浏览器F12工具有哪些变化?
-
Microsoft Edge上手体验:运行速度很快
-
微软全新浏览器Microsoft Edge跑分:完爆IE/Chrome
-
Windows 10全新浏览器终于有名字了:Microsoft Edge
-
微软Microsoft Edge浏览器支持asm.js
-
Microsoft Edge浏览器新待遇 微软为其提供详细的更新日志