贪心
A set of n 1-dimensional items have to be packed in identical bins. All bins have exactly the same length l and each item i has length li<=l . We look for a minimal number of bins q such that
- each bin contains at most 2 items,
- each item is packed in one of the q bins,
- the sum of the lengths of the items packed in a bin does not exceed l .
You are requested, given the integer values n , l , l1 , ..., ln , to compute the optimal number of bins q .
Input
The first line of the input contains the number of items n (1<=n<=10 5) . The second line contains one integer that corresponds to the bin length l<=10000 . We then have n lines containing one integer value that represents the length of the items.
Output
Your program has to write the minimal number of bins required to pack all items.
Sample Input
10 80 70 15 30 35 10 80 20 35 10 30
Sample Output
6
Hint
The sample instance and an optimal solution is shown in the figure below. Items are numbered from 1 to 10 according to the input order.
题解:这道题把输入的数据从大到小排序,然后从最大的开始取,判断最小的能否和它装一起,依次来就行了;
代码:
#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;
bool cmp(int x,int y)
{
return x>y;
}
int main()
{
int n,l;
while(cin>>n)
{
cin>>l;
int a[100010],b[100010];
memset(b,0,sizeof(b));
for(int i=0;i<n;i++)
cin>>a[i];
sort(a,a+n,cmp);
int i=0,j= n-1;
int cnt=0;
while(i<=j)
{
if(a[i]+a[j]<=l && i!=j) j--;
i++;
cnt++;
}
cout<<cnt<<endl;
}
return 0;
}
推荐阅读