1003 Emergency(25 分)
1003 Emergency(25 分)
As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.
Input Specification:
Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.
Output Specification:
For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.
Sample Input:
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
Sample Output:
2 4
dijstra + dfs
#include <iostream>
#include <vector>
#define MAX_SIZE 505
#define INF 123456789
using namespace std;
int n, m, c1, c2, maxi, maxtemp, ways;
int maps[MAX_SIZE][MAX_SIZE]={0}, rescue[MAX_SIZE], d[MAX_SIZE];
vector<int> father[MAX_SIZE];
bool vis[MAX_SIZE] = {false};
void dijsktra()
{
d[c1] = 0;
int i, j, u, mini;
for (i = 0; i < n; i++)
{
u = -1;
mini = INF;
for (j = 0; j < n; j++)
{
if (vis[j] == false && d[j] < mini)
{
u = j;
mini = d[j];
}
}
if (u == -1)
{
return;
}
vis[u] = true;
for (j = 0; j < n; j++)
{
if (vis[j] == false && maps[u][j] > 0)
{
if (maps[u][j] + d[u] < d[j])
{
d[j] = maps[u][j] + d[u];
father[j].clear();
father[j].push_back(u);
}
else if (maps[u][j] + d[u] == d[j])
{
father[j].push_back(u);
}
}
}
}
}
void dfs(int i)
{
maxtemp += rescue[i];
if (i == c1)
{
ways++;
if (maxtemp > maxi)
{
maxi = maxtemp;
}
maxtemp -= rescue[i];
return;
}
for (int j = 0; j < father[i].size(); j++)
{
dfs(father[i][j]);
}
maxtemp -= rescue[i];
}
int main()
{
std::ios::sync_with_stdio(false);
std::cin.tie(0);
int i, t, a, b;
cin >> n >> m >> c1 >> c2;
for (i = 0; i < n; i++)
{
cin >> rescue[i];
}
for (i = 0; i < m; i++)
{
cin >> a >> b >> t;
maps[a][b] = t;
maps[b][a] = t;
}
fill(d, d + MAX_SIZE, INF);
dijsktra();
dfs(c2);
cout << ways << " " << maxi << endl;
return 0;
}
推荐阅读
-
三星Galaxy S20 Ultra优化到位:25W充满5000mAh用时59分钟
-
1086 Tree Traversals Again (25 分)(二叉树的遍历)
-
科学敷面膜时间是多长?敷面膜超过25分钟会发生什么
-
【PAT】B1085 PAT单位排行(25 分)(c++实现)
-
联想Z6 Pro DxOMark拍照成绩公布:95分位列第25
-
iQOO Z3发布会定档3月25日:搭载骁龙768G 跑分超45万
-
7-3 奇数阶魔阵 (25分)
-
14核酷睿i7-12800H现身跑分:单核比锐龙7 5800H快25%
-
PAT 甲级真题 1006 Sign In and Sign Out (25分) python实现
-
PAT (Advanced Level) 1012 The Best Rank (25 分)