UVA - 297:Quadtrees
UVA - 297:Quadtrees
来源:
标签:
参考资料:
相似题目:
题目
A quadtree is a representation format used to encode images. The fundamental idea behind the quadtree is that any image can be split into four quadrants. Each quadrant may again be split in four sub quadrants, etc. In the quadtree, the image is represented by a parent node, while the four quadrants are represented by four child nodes, in a predetermined order.
Of course, if the whole image is a single color, it can be represented by a quadtree consisting of a single node. In general, a quadrant needs only to be subdivided if it consists of pixels of different colors. As a result, the quadtree need not be of uniform depth.
A modern computer artist works with black-and-white images of 32×32 units, for a total of 1024 pixels per image. One of the operations he performs is adding two images together, to form a new image. In the resulting image a pixel is black if it was black in at least one of the component images, otherwise it is white.
This particular artist believes in what he calls the preferred fullness: for an image to be interesting (i.e. to sell for big bucks) the most important property is the number of filled (black) pixels in the image. So, before adding two images together, he would like to know how many pixels will be black in the resulting image. Your job is to write a program that, given the quadtree representation of two images, calculates the number of pixels that are black in the image, which is the result of adding the two images together.
In the figure, the first example is shown (from top to bottom) as image, quadtree, pre-order string (defined below) and number of pixels. The quadrant numbering is shown at the top of the figure.
输入
The first line of input specifies the number of test cases (N) your program has to process.
The input for each test case is two strings, each string on its own line. The string is the pre-order representation of a quadtree, in which the letter‘p’indicates a parent node, the letter ‘f’(full) a black quadrant and the letter‘e’(empty) a white quadrant. It is guaranteed that each string represents a valid quadtree, while the depth of the tree is not more than 5 (because each pixel has only one color).
输出
For each test case, print on one line the text‘There are X black pixels.’, where X is the number of black pixels in the resulting image.
输入样例
3
ppeeefpffeefe
pefepeefe
peeef
peefe
peeef
peepefefe
输出样例
There are 640 black pixels.
There are 512 black pixels.
There are 384 black pixels.
解题思路
参考代码
#include<stdio.h>
#include<string.h>
const int len=32;
const int maxn=1024+10;
char s[maxn];
int buf[len][len],cnt;
//把字符串s[p..]导出到以(r,c)为左上角,边长为w的缓冲区中
//2 1
//3 4
void draw(const char *s,int &p,int r,int c,int w)
{
char ch=s[p++];
if(ch=='p')
{
draw(s,p,r,c+w/2,w/2);//1
draw(s,p,r,c,w/2);//2;
draw(s,p,r+w/2,c,w/2);//3
draw(s,p,r+w/2,c+w/2,w/2);//4
}
else if(ch=='f')//画黑像素(白像素不画)
{
for(int i=r;i<r+w;i++)
for(int j=c;j<c+w;j++)
if(buf[i][j]==0)
{
buf[i][j]=1;
cnt++;
}
}
}
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
memset(buf,0,sizeof(buf));
cnt=0;
for(int i=0;i<2;i++)
{
scanf("%s",s);
int p=0;
draw(s,p,0,0,len);
}
printf("There are %d black pixels.\n",cnt);
}
return 0;
}
上一篇: mysql多表联合查询如何返回一张表的内容_MySQL
下一篇: 设计模式——行为型模式
推荐阅读
-
12306网站日最高访问量达297亿次 如何应对买不到票的情况?
-
LC 297 Serialize and Deserialize Binary Tree
-
团体队列 UVA540 Team Queue
-
丑数(Ugly Numbers, UVa 136)
-
破损的键盘(悲剧文本)(Broken Keyboard(a.k.a. Beiju Text),Uva 11988)
-
集合栈计算机(The SetStack Computer, ACM/ICPC NWERC 2006,Uva12096)
-
唯一的雪花(Unique snowflakes,UVa 11572)滑动窗口+set
-
[UVA - 11584] Partitioning by Palindromes dp预处理
-
UVA227-Puzzle
-
UVA 442 Matrix Chain Multiplication ( stack 应用)