欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

HDU--2602--Bone Collector 【01背包】

程序员文章站 2022-06-06 17:49:46
...

题目链接

Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

HDU--2602--Bone Collector 【01背包】

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output

One integer per line representing the maximum of the total value (this number will be less than 231).

Sample Input

1 5 10 1 2 3 4 5 5 4 3 2 1

Sample Output

14

解题思路:这题非常明显就是01背包问题,01背包就是每种物品只有一个,背包为maxv,要求所装物品价值最大化,这是01背包的经典题型。用va[maxn]来存储每个物品的价值,vo[maxn]存储每个物品的体积,ans[maxn]来存储每一个体积的最大价值,这里用的是一维数组,我们存储一个进去,就是ans[j]=max(ans[j-vo[i]]+va[i],ans[j]),这句怎么理解呢,就是如果要将vo[i]放进背包,那我们就是j-vo[i]+va[i](前j-vo[i]的价值+当前的价值va[i])。如果还不懂得话就根据那几行代码一个一个的在草稿本上列出来,列着列着就懂了,相信自己会懂的。

#include<bits/stdc++.h>
using namespace std;
const int maxn=1e3+1;
int vo[maxn],va[maxn],ans[maxn];
int main(void)
{
	int t,n,m;
	scanf("%d",&t);
	while(t--)
	{
		memset(ans,0,sizeof ans);
		scanf("%d%d",&n,&m);
		for(int i=1;i<=n;i++)
		scanf("%d",&va[i]);
		for(int i=1;i<=n;i++)
		scanf("%d",&vo[i]);
		for(int i=1;i<=n;i++) 
		{
			for(int j=m;j>=vo[i];j--)
			{
				ans[j]=max(ans[j-vo[i]]+va[i],ans[j]);
			}
		}
		printf("%d\n",ans[m]);
	}
	return 0;
}

 

相关标签: 01背包