HDU-2602-Bone Collector(01背包)
程序员文章站
2022-06-06 17:37:22
...
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2602
Bone Collector
Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Output
One integer per line representing the maximum of the total value (this number will be less than 231).
Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1
Sample Output
14
题目很简单,给出石头的数量和背包的最大容量,每块石头的价值、体积,单纯的01背包问题。
代码如下:
代码如下:
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
int main()
{
int T,n,m,value[1001],cost[1001],dp[1001];
cin>>T;
while(T--)
{
cin>>n>>m;
int i,j;
memset(value,0,sizeof(value));
memset(cost,0,sizeof(cost));
memset(dp,0,sizeof(dp));
for(i=1;i<=n;i++)
cin>>value[i];
for(i=1;i<=n;i++)
cin>>cost[i];
for(i=1;i<=n;i++)
{
for(j=m;j>=cost[i];j--)
{
dp[j]=max(dp[j],dp[j-cost[i]]+value[i]);
}
}
cout<<dp[m]<<endl;
}
return 0;
}
上一篇: 章鱼小数据首发全国菜品和酒水大数据
下一篇: 安装dbus-python的简要教程