欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

POJ 2653 Pick-up sticks(线段相交)

程序员文章站 2022-06-03 19:28:51
...

Pick-up sticks

Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 14721   Accepted: 5550

Description

Stan has n sticks of various length. He throws them one at a time on the floor in a random way. After finishing throwing, Stan tries to find the top sticks, that is these sticks such that there is no stick on top of them. Stan has noticed that the last thrown stick is always on top but he wants to know all the sticks that are on top. Stan sticks are very, very thin such that their thickness can be neglected.

Input

Input consists of a number of cases. The data for each case start with 1 <= n <= 100000, the number of sticks for this case. The following n lines contain four numbers each, these numbers are the planar coordinates of the endpoints of one stick. The sticks are listed in the order in which Stan has thrown them. You may assume that there are no more than 1000 top sticks. The input is ended by the case with n=0. This case should not be processed.

Output

For each input case, print one line of output listing the top sticks in the format given in the sample. The top sticks should be listed in order in which they were thrown.

The picture to the right below illustrates the first case from input. POJ 2653 Pick-up sticks(线段相交)

Sample Input

5
1 1 4 2
2 3 3 1
1 -2.0 8 4
1 4 8 2
3 3 6 -2.0
3
0 0 1 1
1 0 2 1
2 0 3 1
0

Sample Output

Top sticks: 2, 4, 5.
Top sticks: 1, 2, 3.

Hint

Huge input,scanf is recommended.

用线段相交判断,直接遍历就好了。

#include<iostream>
#include<algorithm>
using namespace std;
#define maxn 1000060
const double eps=1e-6;
struct line
{
	double x1,y1;
	double x2,y2;
}e[maxn];

bool judge(line a,line b)
{
	if(min(a.x1,a.x2)>max(b.x1,b.x2)||min(a.y1,a.y2)>max(b.y1,b.y2)||min(b.x1,b.x2)>max(a.x1,a.x2)||min(b.y1,b.y2)>max(a.y1,a.y2)) 
	return 0;
	double h,i,j,k;
	h=(a.x2-a.x1)*(b.y1-a.y1)-(a.y2-a.y1)*(b.x1-a.x1);
	i=(a.x2-a.x1)*(b.y2-a.y1)-(a.y2-a.y1)*(b.x2-a.x1);
	j=(b.x2-b.x1)*(a.y1-b.y1)-(b.y2-b.y1)*(a.x1-b.x1);
	k=(b.x2-b.x1)*(a.y2-b.y1)-(b.y2-b.y1)*(a.x2-b.x1);
	return h*i<=eps&&j*k<=eps;
	
}
int main()
{
	ios::sync_with_stdio(0);
	cin.tie(0);
	int n;
	while(cin>>n&&n)
	{
		int j;
		for(int i=1;i<=n;i++)
		{
			cin>>e[i].x1>>e[i].y1>>e[i].x2>>e[i].y2;
		}
		cout<<"Top sticks: ";
		for(int i=1;i<n;i++)
		{
			for(j=i+1;j<=n;j++)
			{
				if(judge(e[i],e[j]))
				{
					break;
				}
			}
			if(j==n+1) cout<<i<<", ";
		}
		cout<<n<<"."<<endl;
	}
	return 0;
}