欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

熄灯问题

程序员文章站 2022-06-02 21:24:10
...

熄灯问题

EXTENDED LIGHTS OUT

总时间限制:
1000ms
内存限制:
65536kB

描述
In an extended version of the game Lights Out, is a puzzle with 5 rows of 6 buttons each (the actual puzzle has 5 rows of 5 buttons each). Each button has a light. When a button is pressed, that button and each of its (up to four) neighbors above, below, right and left, has the state of its light reversed. (If on, the light is turned off; if off, the light is turned on.) Buttons in the corners change the state of 3 buttons; buttons on an edge change the state of 4 buttons and other buttons change the state of 5. For example, if the buttons marked X on the left below were to be pressed,the display would change to the image on the right.

The aim of the game is, starting from any initial set of lights on in the display, to press buttons to get the display to a state where all lights are off. When adjacent buttons are pressed, the action of one button can undo the effect of another. For instance, in the display below, pressing buttons marked X in the left display results in the right display.Note that the buttons in row 2 column 3 and row 2 column 5 both change the state of the button in row 2 column 4,so that, in the end, its state is unchanged.

Note:
1. It does not matter what order the buttons are pressed.
2. If a button is pressed a second time, it exactly cancels the effect of the first press, so no button ever need be pressed more than once.
3. As illustrated in the second diagram, all the lights in the first row may be turned off, by pressing the corresponding buttons in the second row. By repeating this process in each row, all the lights in the first
four rows may be turned out. Similarly, by pressing buttons in columns 2, 3 ?, all lights in the first 5 columns may be turned off.
Write a program to solve the puzzle.

输入
The first line of the input is a positive integer n which is the number of puzzles that follow. Each puzzle will be five lines, each of which has six 0抯 or 1抯 separated by one or more spaces. A 0 indicates that the light is off, while a 1 indicates that the light is on initially.
输出
For each puzzle, the output consists of a line with the string: “PUZZLE #m”, where m is the index of the puzzle in the input file. Following that line, is a puzzle-like display (in the same format as the input) . In this case, 1’s indicate buttons that must be pressed to solve the puzzle, while 0抯 indicate buttons, which are not pressed. There should be exactly one space between each 0 or 1 in the output puzzle-like display.
样例输入

2
0 1 1 0 1 0
1 0 0 1 1 1
0 0 1 0 0 1
1 0 0 1 0 1
0 1 1 1 0 0
0 0 1 0 1 0
1 0 1 0 1 1
0 0 1 0 1 1
1 0 1 1 0 0
0 1 0 1 0 0

样例输出

PUZZLE #1
1 0 1 0 0 1
1 1 0 1 0 1
0 0 1 0 1 1
1 0 0 1 0 0
0 1 0 0 0 0
PUZZLE #2
1 0 0 1 1 1
1 1 0 0 0 0
0 0 0 1 0 0
1 1 0 1 0 1
1 0 1 1 0 1

这里灯的状态就是两种,所以我们用01表示并且使用位运算

#include <memory>
#include <string>
#include <cstring>
#include <iostream>
using namespace std;
int GetBit(char c,int i) {
//取c的第i位
	return ( c >> i ) & 1;
}
void SetBit(char & c,int i, int v) {
//设置c的第i位为v
if( v )
	c |= ( 1 << i);
else
	c &= ~( 1 << i);
}
void Flip(char & c, int i) {
//将c的第i位为取反
	c ^= ( 1 << i);
}
void OutputResult(int t,char result[]) //输出结果
{
cout << "PUZZLE #" << t << endl;
for( int i = 0;i < 5; ++i ) {
	for( int j = 0; j < 6; ++j ) {
	cout << GetBit(result[i],j);
if( j < 5 )
	cout << " ";
}
cout << endl; } }
int main() {
	char oriLights[5]; //最初灯矩阵,一个比特表示一盏灯
	char lights[5]; //不停变化的灯矩阵
	char result[5]; //结果开关矩阵
	char switchs; //某一行的开关状态
	int T;
cin >> T;
for( int t = 1; t <= T; ++ t) {
	memset(oriLights,0,sizeof(oriLights));
for( int i = 0;i < 5; i ++ ) { //读入最初灯状态
	for( int j = 0; j < 6; j ++ ) {
		int s;
		cin >> s;
		SetBit(oriLights[i],j,s);
} }
for( int n = 0; n < 64; ++n ) { //遍历首行开关的64种状态
	memcpy(lights,oriLights,sizeof(oriLights));
		switchs = n; //第i行的开关状态
for( int i = 0;i < 5; ++i ) {
	result[i] = switchs; //第i行的开关方案
for( int j = 0; j < 6; ++j ) {
	if( GetBit(switchs,j)) {
	if( j > 0)
	Flip(lights[i],j-1);//改左灯
	Flip(lights[i],j);//改开关位置的灯
	if( j < 5 )
	Flip(lights[i],j+1);//改右灯
}
 }
if( i < 4 )
	lights[i+1] ^= switchs;//改下一行的灯
	switchs = lights[i]; //第i+1行开关方案和第i行灯情况同
}
if( lights[4] == 0 ) {
	OutputResult(t,result);
	break;
}
} // for( int n = 0; n < 64; n ++ )
}
	return 0;
}

学会程序和算法,走遍天下都不怕
熄灯问题
克什克腾旗阿斯哈图石林

相关标签: 枚举