英文单词排序(java)
程序员文章站
2022-05-28 18:37:10
...
本题要求编写程序,输入若干英文单词,对这些单词按长度从小到大排序后输出。如果长度相同,按照输入的顺序不变。
输入格式:
输入为若干英文单词,每行一个,以#作为输入结束标志。其中英文单词总数不超过20个,英文单词为长度小于10的仅由小写英文字母组成的字符串。
输出格式:
输出为排序后的结果,每个单词后面都额外输出一个空格。
输入样例:
blue
red
yellow
green
purple
输出样例:
red blue green yellow purple
import java.util.ArrayList;
import java.util.Collections;
import java.util.Comparator;
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner in = new Scanner(System.in);
ArrayList<String> arrayList = new ArrayList<String>();
while (true) {
String s = in.next();
if (s.equals("#")) {
break;
}
arrayList.add(s);
}
Collections.sort(arrayList, new Comparator<String>() {
@Override
public int compare(String o1, String o2) {
// TODO Auto-generated method stub
if(o1.length() == o2.length()) {
return 1;
}else {
return o1.length() > o2.length() ? 1 : -1;
}
}
});
for (String ss : arrayList) {
System.out.print(ss + " ");
}
}
}
上一篇: Python练习册(四)——统计英文单词
下一篇: 用 Python 实现英文单词纠错功能