欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

最受欢迎的菜品

程序员文章站 2022-05-26 17:53:03
...

7-2 最受欢迎的菜品 (20分)
某自助餐厅要求餐厅的客人在就餐后进行投票,选出一款最喜爱的菜品,每日营业结束后进行投票统计,选出投票数最多的菜品为最受欢迎的菜品。 请编写一个程序帮助餐厅快速完成这个统计工作。

输入格式:
第1行中给出一个正整数n(不超出1000),表示菜品的数量,每个菜品使用1~n进行编号。 第2行输入若干以空格间隔的正整数,表示客人投出的最喜爱的菜品编号,以键盘结束符^Z或文件结束符结束输入。

输出格式:
每行输出一个最受欢迎的菜品编号和得票数。 菜品编号和得票数间隔1个空格。如果有并列的最受欢迎的菜品,则按编号从小到大的顺序输出每一个菜品,每个菜品占一行。

输入样例:
10
6 8 5 8 9 3 6 6 8 2 1 4 7 2 8 3 8 9 6 3 8 10 6 6
输出样例:
6 6
8 6
代码:
#include <stdio.h>

#define Maxs 1001
int findmax(int a[], int N);
int main()
{
int count[Maxs] = {0};
int n;
scanf("%d", &n);

int x;
while ((scanf("%d", &x))!=EOF)
{
    count[x]++;
}

int maxi = findmax(count, n + 1);

for (int i = 0; i < n + 1; i++)
{
    if (count[maxi] == count[i])
    {
        printf("%d %d\n", i, count[i]);
        //(i == maxi) ? (printf("%d %d", i, count[i])) : (printf("\n%d %d", i, count[i]));
    }
}

return 0;

}

int findmax(int a[], int N)
{
int maxx = 0;

for (int i = 0; i < N; i++)
{
    if (a[maxx] < a[i])
    {
        maxx = i;
    }
}

return maxx;

}

相关标签: c语言 算法