PAT练习1002
1002 A+B for Polynomials (25 分)
This time, you are supposed to find A+B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N1 a N1 N2 a N2 … NK a NKwhere K is the number of nonzero terms in the polynomial, Ni and aNi(i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤NK<⋯<N2<N1≤1000.
Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:
3 2 1.5 1 2.9 0 3.2
#include<stdio.h>
#include<stdlib.h>
const int maxsize = 1111;
double A[maxsize] = {};
int main(){int k;
scanf("%d", &k);
int n;double j;
for(int i = 0;i<k;i++){
scanf("%d %lf", &n, &j);
A[n] = A[n]+j;
}
scanf("%d", &k);
for(int i= 0;i<k;i++){
scanf("%d %lf", &n, &j);
A[n] = A[n]+j;
}
int count = 0;
for(int i = maxsize;i>=0;i--){
if(A[i]!=0){
count++;
}
}
printf("%d",count);
for(int i = maxsize;i>=0;i--){
if(A[i]!=0){
printf(" %d %.1f", i, A[i]);}
}
system("pause");
return 0;
}
//问题:不太懂数组A的为什么maxsize要1111