poj 1979 dfs
程序员文章站
2022-05-21 17:49:53
...
Red and Black
Time Limit: 1000MS | Memory Limit: 30000K | |
Total Submissions: 35582 | Accepted: 19262 |
Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#[email protected]#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### [email protected] ###.### ..#.#.. ..#.#.. 0 0
Sample Output
45 59 6 13
#include <iostream>
#include <queue>
#include <cstring>
using namespace std;
struct node
{
int x;
int y;
node(){}
node(int xx,int yy):x(xx),y(yy){}
};
int n,m;
char g[20][20];
int visit[20][20];
int ans;
int dir[4][2]={{0,1},{0,-1},{1,0},{-1,0}};
void dfs(node start)
{
visit[start.x][start.y]=1;
++ans;
for(int i=0;i<4;i++)
{
node np(start.x+dir[i][0],start.y+dir[i][1]);
if(np.x>=0&&np.x<n&&np.y>=0&&np.y<m&&!visit[np.x][np.y]&&g[np.x][np.y]!='#')
dfs(np);
}
}
int main()
{
while(cin>>m>>n&&(m+n))
{
memset(visit,0,sizeof(visit));
node start;
int cur=0;
for(int i=0;i<n;i++)
for(int j=0;j<m;j++)
{
cin>>g[i][j];
if(g[i][j]=='@')
{
start.x=i;start.y=j;
}
}
ans=0;
dfs(start);
cout<<ans<<endl;
}
return 0;
}
上一篇: POJ1979 Red and Black【DFS】
下一篇: Latex 插入图片