PAT甲级--1147 Heaps(30 分)
1147 Heaps(30 分)
In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))
Your job is to tell if a given complete binary tree is a heap.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.
Output Specification:
For each given tree, print in a line Max Heap
if it is a max heap, or Min Heap
for a min heap, or Not Heap
if it is not a heap at all. Then in the next line print the tree's postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.
Sample Input:
3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56
Sample Output:
Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10
解题思路:首先要知道什么是大顶堆和小顶堆(大顶堆:父亲比孩子节点大,小顶堆则相反)。在判断它是大顶堆还是小顶堆,首先先判断v[0]与v[1]的大小,v[0]大则说明可能是大顶堆,然后去遍历,只要有一个不符合条件的就说明不是堆,同理,v[0]小则说明可能是小顶堆,然后遍历,只要有一个不符合条件就说明不是堆。判断是不是堆后,还要后序遍历并输出。
这个代码是看别人的,这个人敲击厉害:https://www.liuchuo.net/archives/4667
#include<bits/stdc++.h>
using namespace std;
int m,n;
vector<int>a;
void postOrder(int i)
{
if(i>=n) return ;
postOrder(2*i+1);
postOrder(2*i+2);
printf("%d%s",a[i],i==0?"\n":" ");
}
int main(void)
{
scanf("%d%d",&m,&n);
a.resize(n);
for(int i=0;i<m;i++)
{
for(int j=0;j<n;j++) scanf("%d",&a[j]);
int left,right,flag;
flag=a[0]>a[1]?1:-1;
for(int j=0;j<=(n-1)/2;j++)
{
left=2*j+1,right=2*j+2;
if(flag==1&&(a[left]>a[j]||(right<n&&a[right]>a[j]))) flag=0;
if(flag==-1&&(a[left]<a[j]||(right<n&&a[right]<a[j])))flag=0;
}
if(flag==0) printf("Not Heap\n");
else printf("%s Heap\n",flag==1?"Max":"Min");
postOrder(0);
}
return 0;
}
上一篇: Binary Tree Postorder Traversal
下一篇: 二叉树的后序遍历序列
推荐阅读
-
PAT 甲级真题 1006 Sign In and Sign Out (25分) python实现
-
【PAT甲级】【1002】 A+B for Polynomials (25分)
-
PAT甲级 1151 LCA in a Binary Tree (30分) 最近公共祖先
-
[C++] PAT 1143 Lowest Common Ancestor (30分)
-
pat-1143 Lowest Common Ancestor (30分)
-
PAT_甲级_1050 String Subtraction (20分) (C++)【签到题/二分查找/字符串处理】
-
PAT_甲级_1065 A+B and C (64bit) (20分) (C++)【大数相加】
-
PAT(A)1045 Favorite Color Stripe (30分)
-
PAT(A)1038 Recover the Smallest Number (30分)(神奇的sort用法)
-
LCA算法实际应用 PAT (Advanced Level) Practice 1151 LCA in a Binary Tree (30分) 四种方法完成题目+tarjan详细讲解!