欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

树种统计 (25分)

程序员文章站 2022-05-20 09:26:42
...

输入格式:

输入首先给出正整数N(≤10​5​​),随后N行,每行给出卫星观测到的一棵树的种类名称。种类名称由不超过30个英文字母和空格组成(大小写不区分)。

输出格式:

按字典序递增输出各种树的种类名称及其所占总数的百分比,其间以空格分隔,保留小数点后4位。

 输入样例:

29
Red Alder
Ash
Aspen
Basswood
Ash
Beech
Yellow Birch
Ash
Cherry
Cottonwood
Ash
Cypress
Red Elm
Gum
Hackberry
White Oak
Hickory
Pecan
Hard Maple
White Oak
Soft Maple
Red Oak
Red Oak
White Oak
Poplan
Sassafras
Sycamore
Black Walnut
Willow

输出样例:

Ash 13.7931%
Aspen 3.4483%
Basswood 3.4483%
Beech 3.4483%
Black Walnut 3.4483%
Cherry 3.4483%
Cottonwood 3.4483%
Cypress 3.4483%
Gum 3.4483%
Hackberry 3.4483%
Hard Maple 3.4483%
Hickory 3.4483%
Pecan 3.4483%
Poplan 3.4483%
Red Alder 3.4483%
Red Elm 3.4483%
Red Oak 6.8966%
Sassafras 3.4483%
Soft Maple 3.4483%
Sycamore 3.4483%
White Oak 10.3448%
Willow 3.4483%
Yellow Birch 3.4483%

 代码

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<map>
using namespace std;
int cmp (string a,string b){
	return a<b;
}
string te[100001];//用于对map中的key排序
int main(){
	int n,i;
	cin>>n;
	getchar();
	map< string,int,greater<string> >mp;
	string str1,str2;
	for(i=0;i<n;i++){
		getline(cin,str1);
		mp[str1]++;
	}
	i=0;
	map<string,int> :: iterator it;
	for(it=mp.begin();it!=mp.end();it++){
		te[i]=it->first;
		i++;
	}
	
	double b;
	int num=i;
	sort(te,te+i,cmp);
//按te字符串数组中的值为key输出mp中的结果
	for(i=0;i<num;i++){
		str1=te[i];
		b=mp[str1]/(double)n*100;
		cout<<str1<<" ";
		printf("%.4f%%\n",b);
	}
	
	return 0;
}

 

相关标签: PTA