欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

最小公倍数 HDU 1108

程序员文章站 2022-05-17 20:33:00
...

My blog https://dyingdown.github.io/

最小公倍数

Problem

给定两个正整数,计算这两个数的最小公倍数。

Input

输入包含多组测试数据,每组只有一行,包括两个不大于1000的正整数.

Output

对于每个测试用例,给出这两个数的最小公倍数,每个实例输出一行。

Sample Input

10 14

Sample Output

70

Analysis

这个题就是简单的求lcm最小公倍数的题目,公式是
lcm(a,b)=ab÷gcd(a,b) lcm(a, b) = a * b \div gcd(a, b)

Code

#include<bits/stdc++.h>

using namespace std;

int main(){
	int a, b;
	while(cin >> a >> b){
		cout << a * b / __gcd(a, b) << endl;
	}
	return 0;
}
相关标签: Problem