欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

PTA玩转二叉树

程序员文章站 2022-05-17 07:54:12
...

给定一棵二叉树的中序遍历和前序遍历,请你先将树做个镜面反转,再输出反转后的层序遍历的序列。所谓镜面反转,是指将所有非叶结点的左右孩子对换。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其中序遍历序列。第三行给出其前序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树反转后的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:

7
1 2 3 4 5 6 7
4 1 3 2 6 5 7

输出样例:

4 6 1 7 5 3 2
#include<iostream>
#include<queue>
#include <algorithm>
using namespace std;
int pre[10010];
int in[10010];
int pos;

struct Node{
	int w,l,r;
}node[10010];

void input(int a[],int n)
{
	for(int i=0;i<n;i++)
		cin>>a[i];
}

void rec(int l,int r,int n)//重构二叉树 
{
	if(l>=r)
	{
		node[n].w==-1;
		return ;
	}
	int root=pre[pos++];
	node[n].w=root;
	node[n].l=2*n;
	node[n].r=2*n+1;
	int mid=find(in,in+r,root)-in;
	rec(l,mid,2*n);
	rec(mid+1,r,2*n+1);
}

void print()
{
	queue<int>que;
	que.push(1);
	int n;
	while(!que.empty())
	{
		n=que.front();
		que.pop();
		if(node[n].w!=-1)
		{
			if(n!=-1)
			{
				cout<<" ";
			}
			cout<<node[n].w;
			que.push(node[n].r);
			que.push(node[n].l);
		}
	}
	cout<<endl;
}

int main()
{

	int n;
	cin>>n;	
	for(int i=1;i<10010;i++)//初始化为-1 
	{
		node[i].w=-1;
	}
	input(in,n);
	input(pre,n);
	rec(0,n,1);
	print();
	return 0;
}

 

上一篇: 玩转二叉树

下一篇: 玩转二叉树